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Overview

Photon is the Marketcetera Automated Trading Platform Ul client. Photon is what's know as a fat client, meaning it is a standalone native executable as
opposed to a thin client, which is typically made available via a web browser. To use Photon, you must install the Photon component for your platform and
architecture. See the installation guide for more information on installing Photon.

Launching Photon

Photon uses the Eclipse Rich Client Platform. If you're familiar with the Eclipse IDE, Photon will look very familiar to you. On Windows, an entry for Photon
will have been added to your Start menu or Desktop, as you requested during installation. On Linux, to start Photon:

$ cd marketcetera-2.2.1
$ . ./setEnv.sh

$ cd photon

$ ./photon

On OSX, there is a Photon.app which you can add to your toolbar or Applications folder.

Logging In
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Photon can run by itself, however, most of its utility comes from connecting to other components in the Marketcetera Automated Trading Platform stack,
like the Deploy Anywhere Routing Engine and one or more Strategy Engines. Upon start, Photon prompts you to log in to the Deploy Anywhere Routing
Engine (DARE) in the cloud. This system is available for you to use without charge for your evaluation of Marketcetera.

The default credentials for DARE are the same credentials you used to register with Marketcetera Confluence. When you install your own DARE appliance
later, you can set up your own users.

Once you've entered the credentials to connect to DARE, you can tell if Photon has successfully connected by the status icons at the bottom. The icons
will change from

(8 @ Dec2713:09:07 PST

to

@ @ Dec2713:26:23PST

(the left light is for the connection to DARE, the right light is for the connection to the Market Data Nexus, more on that later)

After connecting, some views that require a connection to DARE are populated, like the Open Orders View and the Positions View. More on these and
other views later.

By default, Photon is configured to connect to DARE appliance running in the cloud. However, if you have licensed a DARE appliance for your own data
center, you can configure Photon to connect to that host instead. Select Cancel from the login dialog and then Edit->Preferences. Select Connections in
the left pane.
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You can enter a new IP address (in place of dare.marketcetera.com) for the IP address of your DARE appliance. Select OK and then File->Reconnect
Server to resume the login process. There is also a menubar icon for Reconnect Server, for your convenience. If you are already connected to the server
when you select Reconnect Server, your current connection will be closed and a new connection established. This is harmless, though there may be a
small delay depending on the amount of trading activity that's occurred today as Photon downloads today's activity from DARE.

In addition to the DARE Server connection, there is also a connection to the Market Data Nexus. By default, Photon is expecting a Market Data Nexus
installation on your local host. The Strategy Engine installation by default is configured to also provide a Market Data Nexus instance. The default port is
8998 for the Market Data Nexus.

Perspectives

A Perspective in Photon is a collection of Views that combine to provide a workspace with a specific business function. Perspectives in Photon include
Equity, Option, Future, Currency, and Strategy. You can also create your own Perspectives with a workflow that makes sense to you. Modifications to
Perspectives, including opening, resizing, moving, or closing Views, will be remembered next time you open Photon.

Views

A View in Photon is one of the dockable and resizeable tabs with a title and a menubar. Views may be maximized, minimized, closed, and moved. In
addition to some common Eclipse Views, Photon provides custom Views. Several Views are associated with each Perspective. Additional Views may be
opened by selecting Window->Open View:
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Console View

The Console View is a standard Eclipse View with some Photon-specific customizations.
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There are three sub-views: Main, Sink Console, and Notifications. The Main Console provides basic information from Photon. The default message level is
INFO. This can be changed at Edit->Preferences->Photon.
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The Sink Console displays messages from connected Strategy Agents. There aren't any Strategy Agent connections yet, more on that later.

The Notifications Console displays messages from Photon that correspond to pop-up messages, like server disconnect and reconnect messages, for
example.

Market Data View

Photon provides market data via the Market Data Nexus for display and P&L calculation. Let's take a look at the display of market data. The Marketcetera
Automated Trading Platform divides market data into content types:

Top of Book - best bid and offer

Latest Tick - most recent trade

Marketstat - statistics, including OHLC (open price, high price, low price, and close price)
NASDAQ Level 2 (NQDS) - top-of-book for NASDAQ exchange patrticipants

NASDAQ TotalView (ITCH) - full order book depth for NASDAQ market participants
NYSE OpenBook - limit-order book for all NYSE-traded securities

Aggregated Depth - generic depth data with order sizes aggregated at each price level
Unaggregated Depth - generate depth data no price level aggregation

In Photon, top-of-book, latest tick, and marketstat are displayed in the Market Data View:
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To display market data in the Market Data View, enter a symbol in the Market Data View menubar and press the green plus button or press enter. The
symbol you enter will be submitted to all the active market data adapters. Each adapter will interpret the symbol according to its nature and return market
data accordingly. If more than one market data adapter is active and returning data for the same symbol, the market data displayed will come from the
most recently supplied market data event. Note that, in the above image, there are two equities and one future instrument displayed. Market data can be

displayed for multiple instruments at the same time.

It is important to note that Marketcetera, Inc. does not itself supply market data. Market data comes to the platform via a market data adapter from an
external source, like Thompson Reuters or Lime. You will need an account with one of these providers in order to view market data. More on market data

adapters later.

If the market data event displayed in the Market Data View comes from a market data adapter that supports depth-of-book, you can select a row in the
Market Data View and open the Market Depth View.
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RICK 83.86 83.62 4754 84.38 78.22 91.27 75.82 41445
Bz-201| i Copy SR 31.20 3121 5833 3847 2454 3615 2199 36339

Buy

Sell

View Market Depth » LevelII

Choose columns » TotalView

OpenBook

4|

Ll

I

The available depth views are displayed in the right-click menu for a given row in the Market Data View. Selecting one of the available market data depth
types will open the Market Depth View.
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You can select buy or sell from the right-click menu from either the Market Data or the Market Depth Views. Doing so will open the appropriate Order
Ticket View populated with the bid or ask from the selected row depending on whether you selected buy (ask) or sell (bid).




Order Ticket Views

The Order Ticket Views are used to place new orders and cancel replace order requests. There is a specialized Order Ticket View for each supported
asset class.

Field Type Required Default Equity Option Future Currency Message Field
Broker Dropdown Yes Auto Select | Yes Yes Yes Yes Special®
Side Dropdown Yes Yes Yes Yes Yes Side (54)
Quantity Decimal Yes Yes Yes Yes Yes OrderQty (38)
Symbol String? Yes Yes Yes Yes Yes Symbol (55)
Order Type Dropdown Yes Yes Yes Yes Yes OrdType (40)
Price Decimal 3 Yes Yes Yes Yes Price (44)

Conditional

TIF Dropdown Yes Day Yes Yes Yes Yes TimelnForce (59)
Account String No Yes Yes Yes Yes Account (1)
Iceberg Decimal No Yes Yes Yes Yes MaxFloor (111)
Algo Dropdown No Yes Yes Yes Yes Varies?
Custom Fields Table No Yes Yes Yes Yes Varies®
Expiration Year | Number: YYYY Future No No Yes No MaturityMonthYear (200)
Expiration Month | Dropdown Future No No Yes No MaturityMonthYear (200)
Expiry Number: YYYYMMDD @ Option No Yes No No MaturityMonthYear (200), MaturityDay (205)
Strike Decimal Option No Yes No No StrikePrice (202)
Type Dropdown Option No Yes No No PutOrCall (201)
Open/Close Dropdown No No Yes No No OpenClose (77)
Capacity Dropdown No No Yes No No OrderCapacity (528)
Near Tenor Number: YYYYMMDD ' No No No No Yes FutSettDate (64)
Far Tenor Number: YYYYMMDD ' No No No No Yes SettDate2 (193)
Base Currency = Radio Button Yes CCYy1 No No No Yes Special®

1. The list of available brokers is provided by the Order Routing System. An order may be targeted to a specific broker or the default or "auto-
selected" broker may be selected.

2. The symbol entered is provided to the broker as-is. There is no official symbology for instruments that is respected by all brokers, exchanges, and
market data providers. Some providers accept numeric codes, others use OSI for options, and others use proprietary symbology. This is
exacerbated by symbology of market data providers. In the next major release, the Marketcetera Automated Trading Platform will provide a
symbol standardization system that will make this easier to manage. For now, keep in mind that the symbol in the order ticket has to be
something understood by the broker to which you send the order.

3. Price is required for non-market orders

4. The algo dropdown and table allows you to target an order to a broker-specified algorithm. These algorithms are defined in the Order Routing
System configuration. For example, the broker may offer a special VWAP or TWAP algorithm with parameters that specify participation or start
and end times. These algorithm specifications are part of the broker configuration provided by Marketcetera, Inc. to subscription customers. For
non-subscription customers, you may research and define these algorithms yourself depending on what your broker offers.

5. The custom fields table allows you to specify FIX fields and values on outgoing orders that are not covered by existing widgets on the order ticket.

6. Specifies whether to use the left currency as the base or the right. For example, for the symbol, USD/EUR, CCY1 is USD and CCY2 is EUR. You
may swap these by setting the radio button value to CCY2.

Each asset class has its own Order Ticket View. The Future Order Ticket View is shown here.
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FIX Message Views

Trading History

The FIX Message Views are based on FIX message history provided by DARE. Each FIX message received by DARE from brokers and exchanges
contributes to the FIX message history. That can be a lot of messages! The Marketcetera Automated Trading System has the ability to filter the FIX
message history to just those orders from the current trading session. By default, this feature is enabled and the session start time is set to 00:00:00, local
time. To disable this feature (download all message history) or change the session start time, go to Edit->Preferences->Trading History:
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This feature affects all Views that are based on FIX messages except the Positions View and Open Orders View, which obey special rules. If you change
the Trading History settings, they will take effect the next time you start Photon or you Reconnect to the Server.

FIX Messages Menu

All FIX Message Views offer the same right-click and toolbar menus. To activate the FIX Messages Menu, right-click on a row in one of the FIX Messages
Views.
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15:54:28 15:54:28  Executi.. 138, MEW E EQ AAPL
15:55:33 155533 Executi. 2002  1388178.. (CAMNCELED B EQ AAPL
15:55:48 155548 Executi.. 2001 MEW E EQ AAPL
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View FIX Message Details Menu

This selection opens or refreshes the FIX Message Details View.

Replace Order Menu

This selection opens the Order Ticket View appropriate for the instrument in the message and formats all the fields from the message in order to prepare
an order cancel replace request. This menu item is enabled for open orders only. Note that fields that cannot change in an order cancel replace replace

are disabled.
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Cancel Order Menu

This selection sends an order cancel request based on the given message. This menu item is enabled for open orders only. No confirmation is required;
the cancel request is immediately sent.

Copy Menu

This selection copies a text version of the given message to the system clipboard.
FIX Messages Toolbar

All FIX Messages Views provide the same widgets in the View toolbar.

Filter Toolbar

[ Console | [F] Average Price | ] Fills &3 | [=] FIX Messages | L3 Option Order Ticket| |, Currency Order Ticket Filter: = Symbol~=A*PL @ =]
OrdID  OrdStatus  Side SecurityType Symbol MaturityMonthYear PutOrCall  StrikePrice  OrderQty CumQty LeavesQty OrderPrice  AvgPx Account LastQty ExecPrice Exch  BrokerD Trader
2003 FILLED 5 EQ AAPL 100 100 0 558.95 1 100 brokerl  admin
2004 FILLED 5 EQ AAPL 100 100 0 560.75 1 100 brokerl  admin
2005 PARTIAL 5§ EQ AAPL 100 61 39 560.76 1 61 brokerl  admin

Rows can be filtered with a regular expression based on the column names and values. For example, in the FIX Messages View above, both
"Symbol=AAPL" and "Symbol~=A*PL" would yield the same results. Note the usage of "~=" instead of "=" to activate the regular expression filter.

FIX messages can be sorted by any of the columns. Columns can be dragged to change the column order. You can change the columns displayed in each
FIX Messages View by selecting Edit->Preferences->FIX Columns.
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New View Toolbar

tkerllD | Open new Fills View

Multiple Views of the same type can be opened by selecting the "picture frame" icon. Each View can have different column orders and filter settings.

FIX Message Permissions

All FIX Messages Views rely on FIX Messages as their input, either from the server database or incoming from the message bus. The messages that are
visible are based on the current user. If the current used is a superuser, all messages are visible. If the current user is not a superuser, messages for the
current user only are visible.

FIX Messages View

The FIX Messages View shows all FIX messages in the trading history. Messages from previous trading history sessions are not displayed.

= Console | (] Average Price || Fills |[=] FIX Messages &3 | () Option Order Ticket| (|, Currency Order Ticket Filter: QR~O0
TransactTime | SendingTime MsgType OrdD OrigOrdiD OrdStatus Side SecurityType Symbol MaturityMonthYear PutOrCall StrikePrice  OrderQty CumQty LeavesQty OrdType OrderPrice AvgPx Account LastQty ExecPrice Exch ExedD BrokerOrdD RefSeqNum Brd
£15:54:28 15:54:28  Executi..  138.. NEW. B EQ AAPL 100 0 100 LMT 56009 0 0 1] 68708 68707 brd
15:55:33 155533 Executi. 2002 1388178. CANCELED B  EQ AAPL 100 0 0 LMT 56009 0 0 0 68700 68707 br¢
15:55:48 155548 Executi., 2001 NEW B AAPL 100 0 100 LMT 56000 0 0 0 68711 68710 br¢
15:56:08 155608 Executi., 2003 FILLED s AAPL 100 100 0 LMT 55095 1 100 68714 68712 br¢
15:56:42 155642 Executi., 2004 FILLED s e AAPL 100 100 0 LMT 560.75 1 100 68717 68715 br¢
15:56:59 15:56:59  Executi. 2005 PARTIAL S EQ AAPL 100 61 39 LMT 56076 1 61 68720 68718 brg




FIX Message Details View

The FIX Message Details View shows a tag-by-tag view of a single FIX message. To activate the FIX Message Detail View, select a FIX message in any of
the FIX Message Views and right-click. From the pop-up menu, select View FIX message details.

[ Market Data | >° Market Depth | [+ Future Order Ticket | £ Positions :Jg, Stock Order Ticket |[=] FIX Message Details &3 = 0O
Field Tag Value Value Name Required i
BeginString 8 FIx4.2 false
BodylLength 9 208 false
MsgSegMum 34 12 false =
MsgType 35 ] ExecutionReport false 1
SenderComplD 49 MRETC-EXCH false
SendingTime 52 Fri Dec 27 15:56:59 PST 2013 false
TargetComplD 56 240w-cd-winb4-240 false
BorgPx ] 1 true
ClQrdID 11 2005 falze
CumQty 14 61 true
ExecID 17 68720 true
ExecTransType 20 0 MEW false
LastQty 32 61 false il
Full message: Copy Message][(apyTable
B=FI{4.2 9=208 35=8 34=12 49=-MRKTC-EXCH 52=20131227-23:56:59.137 56=240w-cd-win64-240 6=1 11=2005 14=61 17=68720 -
20=032=61 37=68718 38=100 39=1 40=2 44=560.76 54=2 55=AAPL 59=060=20131227-23:56:59.137 150=1 151=39 167=C510=241

The message can be copied to the system clipboard, either as a text string or a table. Selecting a different row (left-click or right-click) in any of the FIX
Message Views will automatically display the selected message in the FIX Message Details View.

Fills View

The Fills View shows order fills from today's trading session. Like other FIX Message Views, the Fills View supports multiple instances using the picture
frame icon and filtering with regular expressions.

Bl Console | [F| Average Price | [ Fills &3 | [=] FIX Messages| (23 Option Order Ticket Currency Order Ticket Filter: @ =0
OrdID  OrdStatus  Side SecurityType Symbol MaturityMonthYear PutOrCall  StrikePrice  OrderQty CumQty LeavesQty OrderPrice AvgPx Account LastQty ExecPrice Exch BrokerD Trader
12003 FILLED s EQ AAPL 100 100 0 550.95 1 100 brokerl  admin :
2004  FILLED S EQ AAPL 100 100 0 560.75 1 100 brokerl  admin
2005  PARTIAL & EQ AAPL 100 61 Y 560.76 1 61 brokerl  admin

Average Price View

The Average Price View shows the average price of all fills from the current session per instrument.

El Console | = Average Price 52 [ Fills| (=] FIX Messages

Side SecurityType Symbol CumQty HAvgPx
‘5 EQ AMZN 100 550.0000 :
5 EQ DELL 100 575400
5 FOREIGM EXCHANGE COMTRACT  USD/IRY 100 983050

Positions View



The Positions View shows all positions visible to the current user. The Positions View is partially based on FIX
Messages and partially on persisted database state. Similarly to the FIX Messages Views, the contents of the
Positions View are regulated by the permissions of the current user. If the current user is a superuser, all
positions are visible. If the current user is not a superuser, only the current user's positions are visible. Flat
and grouped layouts are available. Select the layout with the Positions View Toolbar icons.

25 Market Data | =] Future Order Ticket | & Pesitions £3 -_:;, Stock Order Ticket | =] FIX Message Details | (24 Option Order Ticket Currency Order Ticket Filter: R E~-T0O0
Underlying Account TraderId Instrument Root Expiry Contract T... Strike Position Incoming Position PL ~ Trading PL Realized PL  Unrealized ... Set Flat Layout
i AAPL accl admin EQ NA NA NA NA -100.00 -100.00 -63.00 0.00 0.00 -63.00 -63.00
DELL acc? admin EQ NA NA MNA NA -100.00 0.00 0.00 1251.00 0.00 1291.00 1291.00
ORCL acc2 admin EQ NA MNA NA NA -100.00 0.00 0.00 50332.00 0.00 5032.00 5033.00
Positions View Flat Layout
[ Market Data | [ Future Order Ticket | £ Positions &3 :‘3 Stock Order Ticket| =] FIX Message Details| L4 Option Order Ticket Currency Order Ticket Filter: = =~ —- 0@ Open Orders 2
Underlying  Account Trader Id Instrument  Root Expiry Contract T...  Strike Pasition Incoming Position PL  Trading PL Realized PL  Unrealized ... Tof Underlying, Account
AAPL accl admin EQ NA NA MNA NA -100.00 -100.00 -911.00 0.00 0.00 -911.00 -01] Underlying, Trader
DELL ace admin EQ NA NA NA NA -100.00 000 0.00 1298.00 0.00 1298.00 129 Account, Underlying
ORCL acc2 admin £ NA NA NA NA -100.00 000 0.00 5076.00 0.00 5076.00 507 pccount, Trader
Trader, Underlying
Trader, Account
Positions View Grouped Layouts
Flat Layout
[ Market Data | [#] Future Order Ticket | £ Pasitions &3 | 7 Stock Order Ticket | (=] FIX Message Details | (2 Option Order Ticket Currency Order Ticket
Underlying  Account TraderId Instrument  Position Incoming Position PL Trading PL Realized PL  Unrealized ... Total PL
AAPL accl admin EQ -100.00 0.00 0.00 336094 0.00 336094 336094
DELL acc? adrmin EQ -100.00 0.00 0.00 1264.00 0.00 126400 1264.00
ORCL acc? admin EQ -100.00 0.00 0.00 507400 0.00 507400 5074.00

The Positions View default layout is the flat non-grouped view.

Grouped Layouts
The Positions View offers several grouped layouts:

Underlying, Account
Underlying, Trader
Account, Underlying
Account, Trader
Trader, Underlying
Trader, Account

The grouped layouts sort the positions into groupings of underlying (instrument), account, and trader. You select the first two by which to group, the third is
selected by default.

[ Market Data | ] Future Order Ticket | £ Pesitions £3 T‘D Stock Order Ticket | [=] FIX Message Details| (3 Option Order Ticket Currency Order Ticket Filter:
Grouping Instrument  Root Expiry Contract T...  Strike Position Incoming Positien PL Trading PL Realized PL  Unrealized ... Total PL
accl -100.00 -100.00 -163.00 0.00 0.00 -163.00 -163.00
4 accl -200.00 0.00 0.00 6340.00 0.00 6340.00 6340.00
a DELL -100.00 0.00 0.00 1299.00 0.00 1293.00 1299.00
4 admin -100.00 0.00 0.00 1293.00 0.00 1293.00 1298.00
DELL EQ NA NA NA NA -100.00 0.00 0.00 1299.00 0.00 1293.00 1299.00
- ORCL -100.00 0.00 0.00 5041.00 0.00 5041.00 504100
Position P&L

Profit and Loss (P&L) information is calculated for positions in the Position View. In addition to (total/current) Position, there is also a column for Incoming
Position. The Incoming Position is the position held at the start of the current trading session. Total Position shows the Incoming position plus any position

changes from today.
There are 5 P&L columns:
® Position PL

® Trading PL
® Realized PL



® Unrealized PL
® Total PL

P&L is calculated based on the active market data feed. The active market data feed must support LATEST_TICK and MARKETSTAT to enable P&L. If
the active market data feed does not support these content types, is unable to deliver the content, or the content is unavailable, P&L will be displayed as N
/A instead.

Open Orders View

The Open Orders View displays all open orders visible to the current user. As in other FIX Message Views, if the current user is a superuser, all open
orders are visible, otherwise, the open orders of only the current user are visible. Open orders are visible regardless of the trading history setting. In other
words, open orders from previous trading sessions will always be displayed.

L] Open Orders &2 Filter: @ &3 =0
SendingTime OrdID OrdStatus  Side SecurityType Symbol  OrderQty CumQty LeavesQty OrderPrice AvgPx  Account LastQty BrokerID Trader

i 12:46:17 4002 MNEW B EQ METLC 100 0 100 1283 0 acctl 0 brokerl admin
12:46:40 138..  MNEW B FOREIGM EX...  USD/... 100 0 100 765.09 0 0 brokerl admin

Strategy Views

The Strategy Views present information related to the creation and execution of strategies. Strategies can be executed in a Strategy Engine. There is a
Strategy Perspective that opens the standard set of Strategy Views. Strategy Views can be opened in any other perspective as desired by selecting the
view from Window->Open View->Other.

Project Explorer View

The Project Explorer View is a standard Eclipse View. It shows strategies available to be deployed in a folder tree.

Li"*5 Project Explorer &3 o 5 ¥ 7 0| HelloWerldjava 2
a == ActiveScripts package sample;
4 [~ Samples
4 = java import org.marketcetera.strate
|=| HelloWg o ]
MarketD Mew Y Project..
|= Movingd Open % File
OrderSe Open With r
p— Fold ;
= Ordersli 5 Folder :
= Processl = Copy Ctrl+C [Ji  Java Strategy
= VWAPSt Paste Ctrl+V | ¢ Ruby Strategy i
+ = rub [
Y # Delete Delete £ Other.. Chrle N
Move...
REname F2 class HelloWorld extend
@ Import.. Executed when the strat
gy Export.. Tse this method to set
and other initializatio
# Refresh F5
Replace With r E?Ilde_
lic vold onStartc () {
Deploy... warn ("Hello World!"™);

Use the Project Explorer View to create new strategies or deploy existing ones to be executed. More on creating and deploying strategies later.

Editor View

The Editor View provides a context and syntax-aware development environment for Java and Ruby strategies. Strategies can be created in this editor or in
external IDE editors and imported.



Outline View
The Outline View shows the method names and some other information about the strategy in the active Editor View.

Strategy Engines View

The Strategy Engines View allows you to manage connections to external Strategy Engines. A Strategy Engine can run both Java and Ruby
strategies. The Strategy Engines View displays all known Strategy Engines. Enabled Engines are connected and live. Disabled Engines are not currently
connected.

To create a new Strategy Engine, select the "create" icon from the Strategy Engines View.

% Strategy Engines &2 — (%_v = def on
Embedded Engine | Add a new strategy agent engine

Local Strategy Agent

' Trade Suggestior

(IS

. Mew Engine (=] @

Add Strategy Agent Connection

Provide the connection and configuration details.

Mame: Remote Strategy Agent

Description: ~ 5A running in Metc datacenter

Configuration

InAS URL: tep:/1010.25.98:61617
Web Service Hostname:  10.10.25.98

Web Service Port: 4001

Finizsh l ’ Cancel

The Strategy Engine connection must match an installed Strategy Engine instance. More on installing Strategy Engines elsewhere.

After creating the Strategy Engines, select it in the Strategy Engines View and connect to it.



ki

‘gn Strategy Engines &% = A = c
&% Embedded Engine 1
2 | ocal Strategy Ag
Gt s
Connect
Disconnect
Deploy...
Start All
[H Stop All
Refresh F5
¥ Delete Delete
Properties Alt+Enter
L

After you connect to the Strategy Engine, you can deploy, undeploy, start, and stop strategies running on that Strategy Engine. To deploy a strategy to a
Strategy Engine, select the strategy in the Project Explorer View. You can deploy one of the sample strategies to start with. Later on, you can create your
own.

\ Project Explorer &7 = ‘& ¥ T O 5 HelloWerld.java 2 hellc
4 == ActiveScripts &
4 [= Samples # SLicenses
4 [= java $
| 2] HelloWorld New X
|= MarketData
= Movinghve Open
|Z| OrderSende Open With b
|=| OrderSlicer,
|Z| ProcessDats iE Copy Ctrl+C
|Z] VWAPStrate Paste Ctrl+V
4 [= ruby K Delete Delete !
j hello_waorld Move... 1
_ﬁ marh.cet_dat Rename... £
3] moving_ave N
4] order_send¢ =3 Import...
¢ order_slicer i3 Export...
_ﬁ process_dat S s !
_ﬁ wvwap_strate = res
Replace With [
Deploy... |
eploy .

To deploy a strategy, give the strategy a unique Instance Name. You can deploy several versions of the strategy on the same Strategy Engine, but each
strategy must have a unique Instance Name. Choose whether the strategy should route its orders to the server or not. If you choose not to route orders to
the server, when you run the strategy, it will create orders but these orders will not be sent. You can use this as a verification step before committing the
strategy to running in production. Choose the engine to which to deploy the strategy.



Configure Deployment
Provide the strategy script and the deployment parameters. @

[plaI:furm:fresuurcefActiveScripI:s,:'SamplesfjauafHelluWurld.javal | Workspace... | | File System... |

Script:
Language: JAVA v
Class: l Hellowerld ]

Instance Name: lHelanurldlnstance ]

Configuration
B Route orders to server

Select engine For deployment:
v " Localhosk Strategy Engine

o

After the strategy is deployed, you can start, stop, and undeploy it from the Strategy Engines View.

[ stategyEngines 23] 5 ¢ 7~ 0| -

28 Embedded Engine
&2 g

Local Strategy Agent @ Tr
a4 58 Remote Strategy Agent
| g8 HelloW—-"— ' [-
| Undeploy
[= Start h‘
Stop
E[;-. Restart
qﬁh Refresh 3]
Properties Alt+Enter

Some strategies accept strategy parameters. You can pass a set of key/value pairs to the strategy by selecting Properties from the Strategy Engines View

popup menu.


https://confluence.marketcetera.com/download/attachments/884762/connections.png?version=2&modificationDate=1400135787000&api=v2

x, Properties for HelloWorldInstance on Rernote Strategy Agent = (== [é]

Configuration @ Configuration S

Instance Mame: HelloWorldInstance

Class: HelloWorld
Language: JAVA
Script:

Route orders to server

Properties specified here will be provided to the strategy as runtime parameters.

Property Value
mnax 5088.00
participaticn 85
syrmbol AAPL

[Add Mew PerEFt_',f]

ok || Concel |

The properties that a strategy expects are particular to that strategy. More on strategy parameters later. When the strategy is ready, start it from the
Strategy Engines View popup menu.

‘% Strategy Engines 7 Ee® ¥ — 0O =
&2 Embedded Engine
Local Strategy Agent

v Al
4 &2 Remote Strategy Agent =
| g8 HelloW—"— : =
| Undeploy
[= Start [}
[H Stop
Restart
" Refresh F5
Properties Alt+Enter

Trade Suggestions

The Trade Suggestions View shows potential trades that a strategy may create. Strategies can send trades directly with no user supervision, or, using the

Trade Suggestions View, strategies may suggest trades that are either confirmed or rejected by a user. Rejected trades are discarded, confirmed trades
are sent to the server and then to a broker just like a regular trade.

L I |
o Trade Suggestions % l = Conso|e| & Problems| R RegExp| T &0 = E]

Source Side  Quantity  Instrument Price  Order Type Score Timestamp Sends the selected orders to the server

¢ Remote Strategy Agent Buy 4329 Equity[symbol=AMZN] 21,12  Limit 1 Mon Dec 30 15:18:34 PST 2013




Trade suggestions are assigned a score by the strategy that creates them. The score is simply a value used to create a preference order for the user
approving them and represent anything you want (scale of 0 to 1, 1 to 10,000, whatever). We'll get in to strategy coding in more detail later, but here's the
snippet that created this trade suggestion:

Order Single order = Factory. getlnstance().createO derSingle();
order.set Order Type(Order Type. Linit);
order.setPrice(inBid.getPrice());
order.setQuantity(inBid.getSize());

order. set Si de( Si de. Buy) ;

order. setlnstrunent (inBid.getlnstrunent());

order. set Ti mel nFor ce(Ti nel nFor ce. Day) ;

suggest Trade(order, Bi gDeci mal . ONE, "Suggested Trade");

You can also open the suggestion in the appropriate Order Ticket View for further modification:

i ' Trade Suggestions % l =] Console| & Problems| R RegExp| ].I\[\,% e - Eli

Source Side Quantity  Instrument Price  Order Type Score Timestamp Opens the trade suggestion in the order ticket view

: Remote Strategy Agent Buy 4329 Equity[symbol=AMZN] 2112  Limit 1 Mon Dec 30 15:18:34 PST 2013
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